import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\da-zA-Z0-9\\-\\_]{16,16}$";
final String string = "ywrckisnxiwfwl2m\n"
+ "fxr1qtqhezpgno-z\n"
+ "(not set)\n"
+ "9ccvg3l-yu40n5kg+aem_ax8r7jqa2j3ad-twccvdltuod3ebjlzpqiypepb7awmspq7mfjptu6jsy_t1u-4naid3djgae8f1xz6xhecbb039j8jkm23xqbssi-byo3ktgg\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}