# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\da-zA-Z0-9\-\_]{16,16}$"
test_str = ("ywrckisnxiwfwl2m\n"
"fxr1qtqhezpgno-z\n"
"(not set)\n"
"9ccvg3l-yu40n5kg+aem_ax8r7jqa2j3ad-twccvdltuod3ebjlzpqiypepb7awmspq7mfjptu6jsy_t1u-4naid3djgae8f1xz6xhecbb039j8jkm23xqbssi-byo3ktgg\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.