// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\da-zA-Z0-9\-\_]{16,16}$").unwrap();
let string = "ywrckisnxiwfwl2m
fxr1qtqhezpgno-z
(not set)
9ccvg3l-yu40n5kg+aem_ax8r7jqa2j3ad-twccvdltuod3ebjlzpqiypepb7awmspq7mfjptu6jsy_t1u-4naid3djgae8f1xz6xhecbb039j8jkm23xqbssi-byo3ktgg
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}