const regex = /^[\da-zA-Z0-9\-\_]{16,16}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\da-zA-Z0-9\\-\\_]{16,16}$', 'gm')
const str = `ywrckisnxiwfwl2m
fxr1qtqhezpgno-z
(not set)
9ccvg3l-yu40n5kg+aem_ax8r7jqa2j3ad-twccvdltuod3ebjlzpqiypepb7awmspq7mfjptu6jsy_t1u-4naid3djgae8f1xz6xhecbb039j8jkm23xqbssi-byo3ktgg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}