#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(?(\d{2})\)?\h?(\d{1}?)\h?(\d)\h?(\d+)\h?(\d?)(\d{3})"
Local $sString = "04 12345678" & @CRLF & _
"" & @CRLF & _
"(04) 1234 5678" & @CRLF & _
"" & @CRLF & _
"041 2345 678" & @CRLF & _
"" & @CRLF & _
"(03)52431234" & @CRLF & _
"" & @CRLF & _
"0412 345 678" & @CRLF & _
"" & @CRLF & _
"0412345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")