$re = '/\(?(\d{2})\)?\h?(\d{1}?)\h?(\d)\h?(\d+)\h?(\d?)(\d{3})/m';
$str = '04 12345678
(04) 1234 5678
041 2345 678
(03)52431234
0412 345 678
0412345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);