using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(?(\d{2})\)?\h?(\d{1}?)\h?(\d)\h?(\d+)\h?(\d?)(\d{3})";
string input = @"04 12345678
(04) 1234 5678
041 2345 678
(03)52431234
0412 345 678
0412345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}