import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?(\\d{2})\\)?\\h?(\\d{1}?)\\h?(\\d)\\h?(\\d+)\\h?(\\d?)(\\d{3})";
final String string = "04 12345678\n\n"
+ "(04) 1234 5678\n\n"
+ "041 2345 678\n\n"
+ "(03)52431234\n\n"
+ "0412 345 678\n\n"
+ "0412345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}