import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*[0-9]{12,})[a-zA-Z0-9)(,'-/\\&.#? ]*$";
final String string = "frf 6666666666996 ere\n"
+ "88888888888\n"
+ "888888888888\n"
+ "8888888888888";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}