re = /^(?!.*[0-9]{12,})[a-zA-Z0-9)(,'-\/\&.#? ]*$/m
str = 'frf 6666666666996 ere
88888888888
888888888888
8888888888888'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end