const regex = /^(?!.*[0-9]{12,})[a-zA-Z0-9)(,'-/\&.#? ]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[0-9]{12,})[a-zA-Z0-9)(,\'-\/\\&.#? ]*$', 'gm')
const str = `frf 6666666666996 ere
88888888888
888888888888
8888888888888`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}