using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a(?<!\bca(?=t\b))";
string input = @"I am a cat in a hat in a car"" except where it appears in the word ""cat"":";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}