$re = '/a(?<!\bca(?=t\b))/m';
$str = 'I am a cat in a hat in a car" except where it appears in the word "cat":';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);