re = /a(?<!\bca(?=t\b))/m
str = 'I am a cat in a hat in a car" except where it appears in the word "cat":'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end