package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[.;]\s+(.*?)[^\w\s]`)
var str = `blah blah. The quick brown fox jumps over the lazy dog?? blah blah
blah balh. The quick brown fox jumps over the lazy dog. blah blah ; The quick brown fox jumps over the lazy dog??
1.22 The quick brown fox jumps over the lazy dog.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}