re = /[.;]\s+(.*?)[^\w\s]/mi
str = 'blah blah. The quick brown fox jumps over the lazy dog?? blah blah
blah balh. The quick brown fox jumps over the lazy dog. blah blah ; The quick brown fox jumps over the lazy dog??
1.22 The quick brown fox jumps over the lazy dog.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end