import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[.;]\\s+(.*?)[^\\w\\s]";
final String string = "blah blah. The quick brown fox jumps over the lazy dog?? blah blah\n\n"
+ "blah balh. The quick brown fox jumps over the lazy dog. blah blah ; The quick brown fox jumps over the lazy dog??\n\n"
+ "1.22 The quick brown fox jumps over the lazy dog.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}