import re
regex = re.compile(r"^(?!.*(\S)(.*\1){3}[^1]?)[]zzSS[-^?!!.'''-*1{33}0066-]{60}\z")
test_str = "['0'z.1\\(3-.]Sz^-)]3}\\.(6^61)[(S}![!1'**6*z\\{}-{{?^3)!?S00?]"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")