re = /^(?!.*(\S)(.*\1){3}[^1]?)[]zzSS[-^?!!.'''-*1{33}0066-]{60}\z/
str = '[\'0\'z.1\\(3-.]Sz^-)]3}\\.(6^61)[(S}![!1\'**6*z\\{}-{{?^3)!?S00?]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end