import Foundation
let pattern = #"^(?!.*(\S)(.*\1){3}[^1]?)[]zzSS[-^?!!.'''-*1{33}0066-]{60}\z"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"['0'z.1\(3-.]Sz^-)]3}\.(6^61)[(S}![!1'**6*z\{}-{{?^3)!?S00?]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}