#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w\s(?P<type>\S+)\s(?P<name>\S+)\s(?P<model>\S+)\s(?P<code>\S+)\s(?P<serial_number>\S+)\s(?P<in_charge>\S+\s\S+\s\S+)"
Local $sString = "X Маршрутизатор Cisco 892FSР" & @CRLF & _
"00206760" & @CRLF & _
"FGL174121B4" & @CRLF & _
"Иванов Иван Иванович" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4 Маршрутизатор Huawei HYFSР23" & @CRLF & _
"00216760" & @CRLF & _
"2FGL174121B4" & @CRLF & _
"Петров Петр Петррович" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")