use strict;
my $str = 'X Маршрутизатор Cisco 892FSР
00206760
FGL174121B4
Иванов Иван Иванович
4 Маршрутизатор Huawei HYFSР23
00216760
2FGL174121B4
Петров Петр Петррович
';
my $regex = qr/\w\s(?P<type>\S+)\s(?P<name>\S+)\s(?P<model>\S+)\s(?P<code>\S+)\s(?P<serial_number>\S+)\s(?P<in_charge>\S+\s\S+\s\S+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}