// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w\s(?P<type>\S+)\s(?P<name>\S+)\s(?P<model>\S+)\s(?P<code>\S+)\s(?P<serial_number>\S+)\s(?P<in_charge>\S+\s\S+\s\S+)").unwrap();
let string = "X Маршрутизатор Cisco 892FSР
00206760
FGL174121B4
Иванов Иван Иванович
4 Маршрутизатор Huawei HYFSР23
00216760
2FGL174121B4
Петров Петр Петррович
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}