import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w\\s(?P<type>\\S+)\\s(?P<name>\\S+)\\s(?P<model>\\S+)\\s(?P<code>\\S+)\\s(?P<serial_number>\\S+)\\s(?P<in_charge>\\S+\\s\\S+\\s\\S+)";
final String string = "X Маршрутизатор Cisco 892FSР\n"
+ "00206760\n"
+ "FGL174121B4\n"
+ "Иванов Иван Иванович\n\n\n"
+ "4 Маршрутизатор Huawei HYFSР23\n"
+ "00216760\n"
+ "2FGL174121B4\n"
+ "Петров Петр Петррович\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}