using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)\s+([\w\s]+)\s+(\d+\.\d+)\s+(\d+)$";
string input = @"12 Hello70 world70 44.14 15
12 Hello70 world70 some12 44.14 15";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}