$re = '/^(\d+)\s+([\w\s]+)\s+(\d+\.\d+)\s+(\d+)$/m';
$str = '12 Hello70 world70 44.14 15
12 Hello70 world70 some12 44.14 15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);