// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+)\s+([\w\s]+)\s+(\d+\.\d+)\s+(\d+)$").unwrap();
let string = "12 Hello70 world70 44.14 15
12 Hello70 world70 some12 44.14 15";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}