re = /^(\d+)\s+([\w\s]+)\s+(\d+\.\d+)\s+(\d+)$/m
str = '12 Hello70 world70 44.14 15
12 Hello70 world70 some12 44.14 15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end