# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[A-Z])(?=[a-z])|(?<=[a-z])(?=[A-Z])/\n/g;t' <<< "ABCcd
abCDE
aaaaBddDDDeeFFggJ"