$re = '/(?<=[A-Z])(?=[a-z])|(?<=[a-z])(?=[A-Z])/';
$str = 'ABCcd
abCDE
aaaaBddDDDeeFFggJ';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;