use strict;
my $str = 'ABCcd
abCDE
aaaaBddDDDeeFFggJ';
my $regex = qr/(?<=[A-Z])(?=[a-z])|(?<=[a-z])(?=[A-Z])/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";