const regex = /(?<=[A-Z])(?=[a-z])|(?<=[a-z])(?=[A-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[A-Z])(?=[a-z])|(?<=[a-z])(?=[A-Z])', 'g')
const str = `ABCcd
abCDE
aaaaBddDDDeeFFggJ`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);