$re = '/(=+ *lien[s]* externe[s]* *=+)\s+([{=[])/is';
$str = '
=== liens externes ===
* {{en}} [http://www.maplandia.com/bosnia-and-herzegovina/federacija-bosne-i-hercegovine/mostar/ Maplandia]
{{en}} [http://www.maplandia.com/bosnia-and-herzegovina/federacija-bosne-i-hercegovine/mostar/ Maplandia]
=== lien externe ===
=== liens externes ===
* [[Villes de Bosnie-Herzégovine]]
* [[Municipalités de Bosnie-Herzégovine]]
* [[Viticulture en Bosnie-Herzégovine]]
=== Liens externes ===
{{Palette|Ville de Mostar|Villes de Bosnie-Herzégovine}}
{{Portail|Bosnie-Herzégovine}}
[[Catégorie:Mostar|*]]
[[Catégorie:Localité de Mostar]]
=== Liens externes ===
[[Catégorie:Mostar|*]]
[[Catégorie:Localité de Mostar]]
=== Liens externes ===
';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;