# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(=+ *lien[s]* externe[s]* *=+)\s+([{=[])"
test_str = ("\n"
"=== liens externes ===\n\n"
"* {{en}} [http://www.maplandia.com/bosnia-and-herzegovina/federacija-bosne-i-hercegovine/mostar/ Maplandia]\n\n"
"{{en}} [http://www.maplandia.com/bosnia-and-herzegovina/federacija-bosne-i-hercegovine/mostar/ Maplandia]\n\n"
"=== lien externe ===\n\n\n\n"
"=== liens externes ===\n\n"
"* [[Villes de Bosnie-Herzégovine]]\n"
"* [[Municipalités de Bosnie-Herzégovine]]\n"
"* [[Viticulture en Bosnie-Herzégovine]]\n\n"
"=== Liens externes ===\n\n\n\n"
"{{Palette|Ville de Mostar|Villes de Bosnie-Herzégovine}}\n"
"{{Portail|Bosnie-Herzégovine}}\n\n"
"[[Catégorie:Mostar|*]]\n"
"[[Catégorie:Localité de Mostar]]\n\n"
"=== Liens externes ===\n\n\n"
" \n"
"[[Catégorie:Mostar|*]]\n"
"[[Catégorie:Localité de Mostar]]\n\n"
"=== Liens externes ===\n\n\n\n")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.