re = /(=+ *lien[s]* externe[s]* *=+)\s+([{=[])/i
str = '
=== liens externes ===
* {{en}} [http://www.maplandia.com/bosnia-and-herzegovina/federacija-bosne-i-hercegovine/mostar/ Maplandia]
{{en}} [http://www.maplandia.com/bosnia-and-herzegovina/federacija-bosne-i-hercegovine/mostar/ Maplandia]
=== lien externe ===
=== liens externes ===
* [[Villes de Bosnie-Herzégovine]]
* [[Municipalités de Bosnie-Herzégovine]]
* [[Viticulture en Bosnie-Herzégovine]]
=== Liens externes ===
{{Palette|Ville de Mostar|Villes de Bosnie-Herzégovine}}
{{Portail|Bosnie-Herzégovine}}
[[Catégorie:Mostar|*]]
[[Catégorie:Localité de Mostar]]
=== Liens externes ===
[[Catégorie:Mostar|*]]
[[Catégorie:Localité de Mostar]]
=== Liens externes ===
'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result