# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[!\"]+([^!\"]+)[!\"]"
test_str = ("!img2.png|width=83.33333333333334%!\n\n"
" \"!robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400!\" \n\n"
" \"!abc.pdf|width=200!\"\n\n"
" \"!dfe.xlx\"\n"
" !\"dfe.xlx!\"\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.