// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[!"]+([^!"]+)[!"]"#).unwrap();
let string = "!img2.png|width=83.33333333333334%!
\"!robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400!\"
\"!abc.pdf|width=200!\"
\"!dfe.xlx\"
!\"dfe.xlx!\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}