import Foundation
let pattern = #"[!"]+([^!"]+)[!"]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
!img2.png|width=83.33333333333334%!
"!robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400!"
"!abc.pdf|width=200!"
"!dfe.xlx"
!"dfe.xlx!"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)