import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[Uu]\\w{0,10}\\s*[Mm]*\\w{0,4}(\\,)*\\s*[Rr]*\\w{0,3}\\s*\\w{0,1}\\s*[Pp]*\\w{0,9}\\s\\w{0,2}\\s*[Ss]\\w{0,2}\\s*[Ff]\\w{0,8}\\s*[Xx]\\w{0,5}\\s*\\w{0,2}\\s*[Cc]*\\w{0,9}";
final String string = "Universidad Mayor, Real y Pontificia de San Francisco Xavier de Chuquisaca\n"
+ "universidad mayor, real y pontificia de san francisco xavier de chuquisaca\n"
+ "USFX\n"
+ "usfx\n"
+ "Universidad San Francisco Xavier\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}