$re = '/^[Uu]\w{0,10}\s*[Mm]*\w{0,4}(\,)*\s*[Rr]*\w{0,3}\s*\w{0,1}\s*[Pp]*\w{0,9}\s\w{0,2}\s*[Ss]\w{0,2}\s*[Ff]\w{0,8}\s*[Xx]\w{0,5}\s*\w{0,2}\s*[Cc]*\w{0,9}/m';
$str = 'Universidad Mayor, Real y Pontificia de San Francisco Xavier de Chuquisaca
universidad mayor, real y pontificia de san francisco xavier de chuquisaca
USFX
usfx
Universidad San Francisco Xavier
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);