use strict;
my $str = 'Universidad Mayor, Real y Pontificia de San Francisco Xavier de Chuquisaca
universidad mayor, real y pontificia de san francisco xavier de chuquisaca
USFX
usfx
Universidad San Francisco Xavier
';
my $regex = qr/^[Uu]\w{0,10}\s*[Mm]*\w{0,4}(\,)*\s*[Rr]*\w{0,3}\s*\w{0,1}\s*[Pp]*\w{0,9}\s\w{0,2}\s*[Ss]\w{0,2}\s*[Ff]\w{0,8}\s*[Xx]\w{0,5}\s*\w{0,2}\s*[Cc]*\w{0,9}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}