const regex = /^[Uu]\w{0,10}\s*[Mm]*\w{0,4}(\,)*\s*[Rr]*\w{0,3}\s*\w{0,1}\s*[Pp]*\w{0,9}\s\w{0,2}\s*[Ss]\w{0,2}\s*[Ff]\w{0,8}\s*[Xx]\w{0,5}\s*\w{0,2}\s*[Cc]*\w{0,9}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[Uu]\\w{0,10}\\s*[Mm]*\\w{0,4}(\\,)*\\s*[Rr]*\\w{0,3}\\s*\\w{0,1}\\s*[Pp]*\\w{0,9}\\s\\w{0,2}\\s*[Ss]\\w{0,2}\\s*[Ff]\\w{0,8}\\s*[Xx]\\w{0,5}\\s*\\w{0,2}\\s*[Cc]*\\w{0,9}', 'gm')
const str = `Universidad Mayor, Real y Pontificia de San Francisco Xavier de Chuquisaca
universidad mayor, real y pontificia de san francisco xavier de chuquisaca
USFX
usfx
Universidad San Francisco Xavier
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}