import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(abc.?\\s*(\\b\\s\\w+\\s\\b){0,7}\\s*\\bsome\\s*name\\b)";
final String string = "abc/ef 12,345 some name\n\n"
+ "abc/ef 12345 some name";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}