$re = '/(abc.?\s*(\b\s\w+\s\b){0,7}\s*\bsome\s*name\b)/m';
$str = 'abc/ef 12,345 some name
abc/ef 12345 some name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);