const regex = /(abc.?\s*(\b\s\w+\s\b){0,7}\s*\bsome\s*name\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(abc.?\\s*(\\b\\s\\w+\\s\\b){0,7}\\s*\\bsome\\s*name\\b)', 'gm')
const str = `abc/ef 12,345 some name
abc/ef 12345 some name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}