#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!--).)*\bfoobar\b"
Local $sString = "Match: SELECT foobar" & @CRLF & _
"Match: , foobar" & @CRLF & _
"Exclude: SELECT baz -- foobar" & @CRLF & _
"Exclude: -- foobar" & @CRLF & _
"Exclude: ---foobar" & @CRLF & _
"Exclude: -- blah foobar blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")