using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!--).)*\bfoobar\b";
string input = @"Match: SELECT foobar
Match: , foobar
Exclude: SELECT baz -- foobar
Exclude: -- foobar
Exclude: ---foobar
Exclude: -- blah foobar blah";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}