re = /^(?:(?!--).)*\bfoobar\b/m
str = 'Match: SELECT foobar
Match: , foobar
Exclude: SELECT baz -- foobar
Exclude: -- foobar
Exclude: ---foobar
Exclude: -- blah foobar blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end