$re = '/^(?:(?!--).)*\bfoobar\b/m';
$str = 'Match: SELECT foobar
Match: , foobar
Exclude: SELECT baz -- foobar
Exclude: -- foobar
Exclude: ---foobar
Exclude: -- blah foobar blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);