using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<type>([a-z]*))((?P<dev>[0-9]+).)?((?P<module>[0-9]+).)?((?P<port>[0-9]+))$";
string input = @"tengigabitethernet1-24
gigabitethernet0/0-1
1/1
g1/1/1
1/1/1
1.1
1-1
1_1
1.1.1
eth0.10
eno3p4
enp4s0f0
vmbr1.10
britge0.50";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}